1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grim Dawn Guide

Discussion in 'Guides' started by booman, Jan 2, 2015.

  • by booman, Jan 2, 2015 at 1:19 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Virginia
    Home page:
    Grim Dawn is an action hack-n-slash created by the makers of Titan Quest. Slaughter minions and bosses in a dark fantasy world of exploration, loot, hacking, slashing and a lot of skills! Do not miss this game! You will love the AAA experience from a small indie team who are very talented and passionate about Action RPG's!



    Follow my step-by-step guide on installing, configuring and optimizing Grim Dawn in Linux with PlayOnLinux.

    Note: This guide applies to the Steam version of Grim Dawn. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.6
    Wine: 1.7.39staging

    Wine Installation

    Note: Versions of Wine older than 2.0.2 and Wine 2.12-staging no longer work with Steam

    Click Tools
    Select "Manage Wine Versions"

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.7.39staging is installed and you can close this window

    Downloading Steam

    Go To: http://www.steampowered.com
    Click Install Steam

    Do not click "Install Steam Now"
    It will automatically install Linux Steam. Since Grim Dawn isn't made for Linux, we will download the Windows Steam instead.
    click "Windows" under the green button

    Navigate to your desktop
    Click Save

    Setup PlayOnLinux

    Launch PlayOnLinux
    Click Install

    Click "install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name you virtual drive: grimdawn
    Click Next

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine 1.7.39staging
    Click Next

    Select "32 bits windows installation"
    Click Next

    Configure Wine

    Applications Tab
    Windows Version: Windows 7
    Click Apply

    Graphics Tab
    Check: Automatically capture the mouse in full-screen windows
    Check: Emulate a virtual desktop
    Desktop size: 1024x768
    Click Ok

    Install Libraries

    Check the following libraries:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    • POL_Install_vcrun2010
    • POL_Install_vcrun2012
    Click Next
    Note: vcrun2015 will be installed later in PlayOnLinux configure

    Installing Steam

    Click Browse

    Navigate to your desktop
    Select: SteamSetup.exe
    Click Open

    Click Next

    Click Next

    Check: I accept the license...
    Click Next

    Click Next

    Click Next

    Click Install

    Click Finish

    More downloading, updating, extracting and installing

    When Steam is done installing the login screen will pop up. You probably won't see any text because there is a font bug.
    Click the "X" to close Steam login

    PlayOnLinux Shortcut

    Select Steam.exe
    Click Next

    Name your shortcut: Grim Dawn
    Click Next

    Click Next

    PlayOnLinux Configure

    Back to PlayOnLinux
    Click Configure

    General Tab
    Wine version: 1.7.39staging
    Arguments: -no-dwrite -no-cef-sandbox
    This fixes the missing font and store problem

    Display Tab
    Video Memory Size: Select the size of Memory your video card/chip uses

    Installing vcrun2015

    Note: vcrun2015 has to be installed before first launch of Grim Dawn. Otherwise the game installs vcrun2015 for you and breaks Wine. If you accidentally launch Grim Dawn one time, you will have to delete the virtual drive and start over from the beginning.

    Miscellaneous Tab
    Click "Open a Shell"
    wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
    Press Enter

    chmod +x winetricks
    Press Enter

    WINEPREFIX=/home/username/.PlayOnLinux/wineprefix/grimdawn ./winetricks -q vcrun2015
    Press Enter

    Note: Replace "username" with your login

    Close Shell

    Close Configure

    Launching Steam

    Select Grim Dawn
    Click Run

    Click "Login to existing account"


    Steam Overlay

    Steam overlay has been known to cause problems launching games.
    Click Steam menu
    Click Settings

    Select "In-game"
    Uncheck "Enable Steam Community In-Game"
    Click OK

    Installing Grim Dawn

    Click Library
    Select Grim Dawn
    Click Install

    Click Next

    Click Next

    Click Finish

    Wait while Grim Dawn downloads

    Click Play


    Click Options

    Click Video
    Change Window Mode to Fullscreen
    Select Resolution to match your Linux Desktop

    Anisotropic Filtering
    Detail Level

    Vertical Sync
    Triple Buffering
    Detail Objects
    Post Processing
    Depth of Field
    Soft Particles

    Click OK to apply settings

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    Grim Dawn didn't have too many problems with my GeForce 550 Ti. Tested with Wine 1.7.39 staging and now everything runs beautifully with hardly any lag. There were a few times when the game slowed down because of all the minions in the screen. Lowering the anti-Alias and Anisotropic filtering helped. I also tried adjusting fX and Lighting to produce better performance while it didn't affect the visuals. There were a few occurrences where my character had invisible texture upon loading. Quitting the game and launching again would fix this problem.

    Texture/Font Bugs:
    There is some texture reload issues in Grim Dawn that can be resolved by adding launch option in Steam:
    To fix any missing textures:
    1. Configure
    2. Wine Tab
    3. Registry
    4. Navigate to
    5. right-click Direct3D
    6. Select New
    7. String Value
    8. Name:
    9. Value: enable

    Gameplay Video:









    Last edited: Nov 13, 2017
    HTC and Grantuu like this.
  • Categories:


Discussion in 'Guides' started by booman, Jan 2, 2015.

  1. skweresp
    I install with playonlinux and now everything is OK. Have some graphics glitches but add /d3d9 to launching options solved issues.
  2. booman
    What were the graphical glitches? I notice problems with the ground textures loading. Sometimes they load properly and other times they don't.
  3. skweresp
    As You said, ground textures, shadows, blood blows and button texts on first game menu.
  4. booman
    Yes me too! How did you fix it?
    Which d3d package did you install?
  5. skweresp
    I add "/d3d9" to game launch options in steam.
  6. booman
    No way! I've been playing co-op with my wife for many hours and had no idea of this command.
    Thank You!!!
  7. skweresp
    I was wrong, sometimes I have graphics issues like today it looks like that:
  8. booman
    Yup! Those are the problems I've been experiencing for a long time. They come and go.

    I have fixed it before with a registry edit:
  9. skweresp
    Thanks I will try it, but I don't have any issueas until last update.
    booman likes this.
  10. booman
    No problem. I wish they would just port it to Linux for us!
  11. jury
    I have got Grim Dawn from GOG couple days ago, but can not make it run :/
    It installs fine, but each time when I run it all I get is a black screen with grim dawn cursor + I can hear menu music.
    I tried clean wine and playonlinux ( with few different wine versions ) and its always the same. I have downloaded Grim Dawn from some torrent and this installs and plays just fine. Only problem is sometimes missing textures, but CheckFloatConstants="enabled" solved in 100%
    But I would like to play version and I guess this vcrun2015 is somehow the problem. But before installing the game I install vcrun2015 through winetricks. Any clues are welcome :)
  12. booman
    So you can hear the game running but can't see anything?

    Try disabling the Virtual Desktop in Wine Configuration.
  13. jury
    Yes, exactly, I can hear the game running, but the screen is completely black and all I can see is the mouse cursor ( the Grim Dawn one )
    And if it goes for Virtual Desktop it is disabled :(
  14. jury
    I'm on Mint 17.3 but tested Grim Dawn version on Mint 18.1 which I have through VirtualBox. And it works fine ( except huge slowdown :) ) graphics are just OK. Now I have to find out what's different between 17.3 and 18.1 and try to upgrade it on 17.3 as I will not upgrade my 17.3 probably for a long time. Any advices of course are welcome ;)
  15. booman
    Hmm, that is interesting. Even when I had Mint 17.3 I still experienced the invisible game problem. What video card/chip are you using? Do you have open source or proprietary drivers installed?
  16. jury
    I have nVidia GTX750 TI and use proprietary drivers. But tomorrow I will install it again and check under open source drivers, just for curiosity.
    What version of Grim Dawn do you use?
  17. booman
    Great! Try installing Nvidia 384 or newer.

    I don't know exactly what version of Grim Dawn, but I did update the game and tested. Works fine so far.
  18. HTC
    This guide helped me play this game (currently the only game i'm playing) for about 1 month or so.

    Game was running OK until 2 days ago (not counting the almost invisible portals) but, since then, i've been plagued with graphical glitches and it's impossible to play. I'm a noob when it comes to Linux (ditched windows about 2 months ago and am currently using Ubuntu 16.04), so please keep that in mind when suggesting possible solution(s).

    Here's a pic of the problem but it much MUCH worse then the picture indicates because the screen alternates between what's in the pic and total black screen, quite rapidly: i66.tinypic.com/zxodjs.png

    Tried many things, including upgrading to Ubuntu 17.10 and even a fresh 17.10 install, but the problem persists: have no idea what is wrong :(

  19. HTC
    Forgot to mention (can't seem to edit the reply i gave earlier): i'm using a sapphire nitro+ 4GB RX480 with a Ryzen 1600, both @ stock speeds.

    Was using Oibaf before but that was before re-installing Ubuntu 16.04, again: currently with Padoka. Wanted to see if Oibaf was part of the problem but apparently not, since i get the same prob with Padoka.
  20. booman
    Hi HTC, welcome to our humble forum.
    I've had glitches in the past, but have been fixed by forcing Grim Dawn to run in direct X 9 mode and the FloatConstants enabled in the registry.

    Your screenshot though looks like a driver-related problem. I don't have any AMD video cards, but in the past their drivers have been problematic.

    Do you have any graphical artifacts in your other games?
    Have you tried updating/downgrading your video drivers?

    Note: you can't edit your posts until you reach 15 posts.

Share This Page