1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grim Dawn Guide

Discussion in 'Guides' started by booman, Jan 2, 2015.

  • by booman, Jan 2, 2015 at 1:19 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Virginia
    Home page:
    Grim Dawn is an action hack-n-slash created by the makers of Titan Quest. Slaughter minions and bosses in a dark fantasy world of exploration, loot, hacking, slashing and a lot of skills! Do not miss this game! You will love the AAA experience from a small indie team who are very talented and passionate about Action RPG's!



    Follow my step-by-step guide on installing, configuring and optimizing Grim Dawn in Linux with PlayOnLinux.

    Note: This guide applies to the Steam version of Grim Dawn. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.6
    Wine: 1.7.39staging

    Wine Installation

    Note: Versions of Wine older than 2.0.2 and Wine 2.12-staging no longer work with Steam

    Click Tools
    Select "Manage Wine Versions"

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.7.39staging is installed and you can close this window

    Downloading Steam

    Go To: http://www.steampowered.com
    Click Install Steam

    Do not click "Install Steam Now"
    It will automatically install Linux Steam. Since Grim Dawn isn't made for Linux, we will download the Windows Steam instead.
    click "Windows" under the green button

    Navigate to your desktop
    Click Save

    Setup PlayOnLinux

    Launch PlayOnLinux
    Click Install

    Click "install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name you virtual drive: grimdawn
    Click Next

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine 1.7.39staging
    Click Next

    Select "32 bits windows installation"
    Click Next

    Configure Wine

    Applications Tab
    Windows Version: Windows 7
    Click Apply

    Graphics Tab
    Check: Automatically capture the mouse in full-screen windows
    Check: Emulate a virtual desktop
    Desktop size: 1024x768
    Click Ok

    Install Libraries

    Check the following libraries:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    • POL_Install_vcrun2010
    • POL_Install_vcrun2012
    Click Next
    Note: vcrun2015 will be installed later in PlayOnLinux configure

    Installing Steam

    Click Browse

    Navigate to your desktop
    Select: SteamSetup.exe
    Click Open

    Click Next

    Click Next

    Check: I accept the license...
    Click Next

    Click Next

    Click Next

    Click Install

    Click Finish

    More downloading, updating, extracting and installing

    When Steam is done installing the login screen will pop up. You probably won't see any text because there is a font bug.
    Click the "X" to close Steam login

    PlayOnLinux Shortcut

    Select Steam.exe
    Click Next

    Name your shortcut: Grim Dawn
    Click Next

    Click Next

    PlayOnLinux Configure

    Back to PlayOnLinux
    Click Configure

    General Tab
    Wine version: 1.7.39staging
    Arguments: -no-dwrite -no-cef-sandbox
    This fixes the missing font and store problem

    Display Tab
    Video Memory Size: Select the size of Memory your video card/chip uses

    Installing vcrun2015

    Note: vcrun2015 has to be installed before first launch of Grim Dawn. Otherwise the game installs vcrun2015 for you and breaks Wine. If you accidentally launch Grim Dawn one time, you will have to delete the virtual drive and start over from the beginning.

    Miscellaneous Tab
    Click "Open a Shell"
    wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
    Press Enter

    chmod +x winetricks
    Press Enter

    WINEPREFIX=/home/username/.PlayOnLinux/wineprefix/grimdawn ./winetricks -q vcrun2015
    Press Enter

    Note: Replace "username" with your login

    Close Shell

    Close Configure

    Launching Steam

    Select Grim Dawn
    Click Run

    Click "Login to existing account"


    Steam Overlay

    Steam overlay has been known to cause problems launching games.
    Click Steam menu
    Click Settings

    Select "In-game"
    Uncheck "Enable Steam Community In-Game"
    Click OK

    Installing Grim Dawn

    Click Library
    Select Grim Dawn
    Click Install

    Click Next

    Click Next

    Click Finish

    Wait while Grim Dawn downloads

    Click Play


    Click Options

    Click Video
    Change Window Mode to Fullscreen
    Select Resolution to match your Linux Desktop

    Anisotropic Filtering
    Detail Level

    Vertical Sync
    Triple Buffering
    Detail Objects
    Post Processing
    Depth of Field
    Soft Particles

    Click OK to apply settings

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    Grim Dawn didn't have too many problems with my GeForce 550 Ti. Tested with Wine 1.7.39 staging and now everything runs beautifully with hardly any lag. There were a few times when the game slowed down because of all the minions in the screen. Lowering the anti-Alias and Anisotropic filtering helped. I also tried adjusting fX and Lighting to produce better performance while it didn't affect the visuals. There were a few occurrences where my character had invisible texture upon loading. Quitting the game and launching again would fix this problem.

    Texture/Font Bugs:
    There is some texture reload issues in Grim Dawn that can be resolved by adding launch option in Steam:
    To fix any missing textures:
    1. Configure
    2. Wine Tab
    3. Registry
    4. Navigate to
    5. right-click Direct3D
    6. Select New
    7. String Value
    8. Name:
    9. Value: enable

    Gameplay Video:









    Last edited: Nov 13, 2017
    HTC and Grantuu like this.
  • Categories:


Discussion in 'Guides' started by booman, Jan 2, 2015.

  1. Grantuu

    I got some problems getting Grim Dawn to work on my system.
    I run Mint 18. I can do all steps including downloading the game via steam in WINE 1.7.39staging and 1.8.5. In followed the guide step by step but I can't run the Game at all.
    In 1.7.39staging I get an Error when I click play in steam and the Game shuts down. The error message can not be generated.
    In 1.8.5 I get an Error with the steamwebhelper already during the download and also after failed atempts to start the game in steam. here's my pastebin: http://pastebin.com/duCRr7Yu

    Does Grim Dawn even run in it's current state on Linux?
    And if so could you please help me resolve this problem. Your help is much apreciated.
  2. booman
    Welcome to the forum. I'm glad you are trying Grim Dawn because I am currently playing with my wife in Mint 18.
    It is running fairly nice for both of us. I get that missing texture problem here and there, but otherwise it runs.

    As for your log, I need all of the log before the crash. Are you able to install Steam and successfully download Grim Dawn?

    That is the first step, then before you launch it make sure to install vcrun2015
    Otherwise Steam will install it for you and it won't work.

    Unfortunately you will need to start over, but if you do it in that order, it should run
    Grantuu likes this.
  3. Grantuu
    I can install Steam and download Grim Dawn without any problems. I don't even have the "no text" bug when first opening Steam after installation. What log exactly do you need? I'm still a Linux Newbie.
    I think I have some issues with the installation of vcrun2015. I follow the guide. It says "already installed" if I --force it I can uninstall it through the Wizard and then reinstall it via -g. Still didn't work.
    When running Grim Dawn for the first time it will still install vcrun2015 for some reason even though i installed it previously.

    Do I install Steam and Grim Dawn first and then install vcrun2015? I installed Steam then vcrun2015 then grim dawn.

    And also the arguments for the configuration of the virtual drive "-no-dwrite -no-cef-sandbox" look different from what you have in you screenshot. wich ones do I use?

    Thanks for your quick reply.
  4. Grantuu
    Now for some reason I can't even install vcrun2015 anymore.
    Either it will say "already installed" in wich case i'll --force and uninstall vcrun2015 and it also says missing mfc140.dll wich I downloaded and C&P into the directory, wich solved at least that message.
    Or it will give me the following Error and will not complete the installation. Pastebin: http://pastebin.com/R1BPZ7uM
    I tried googling about it but couldn't find anything helpful.
    This problem persists even after I dele the virtual drive and create a new one, even if I name it completely different from any previous virtual drive.

    Any help is very much apreciated.
  5. booman
    I wonder if Steam is installing vcrun2015 first? I've never experienced this, and I don't think Steam requires it.

    Try starting over with a brand new 32-bit virtual drive like this:
    • Launch PlayOnLinux
    • Click Configure
    • Click New (Bottom Left)
    • Name the virtual drive
    • Select 32-bit
    • Next, Next, etc
    Now you have a bare-bones virtual drive.
    1. Select it on the left-side and click the Miscellaneous Tab
    2. Click open a shell/command line button and follow the steps for vcrun2015
    3. When its complete, stay on the Miscellaneous Tab
    4. Click "Run a .exe file in this virtual drive"
    5. Find your Steam Installer .exe
    6. Follow all the steps for installing Steam
    7. You can create a new shortcut from the General Tab
    8. Name it Grim Dawn
    9. Don't forget -no-dwrite -no-cef-sandbox in arguments
    10. Click the "Install Components" Tab
    11. Install the recommended packages in the guide
    12. Click Wine Tab
    13. Click "Wine Configuration"
    14. Set Windows 7 and Mouse Checkbox
    15. Close Configure
    16. Now launch Steam with "Debug" not RUN
    17. Login and Download Grim Dawn
    18. You can actually copy the Grim Dawn folder from the SteamApps/Common directory to your new virtual drive. This speeds up the download process
    19. Launch Grim Dawn
    20. It should try to install dependencies like visual C and Direct X
    21. If it still crashes, copy the debug again and post it.
    Grantuu likes this.
  6. Grantuu
    Hello booman,

    thanks again for your quick and detailed help. I had few little issues while following your instructions but could resolve most of them till I got to the point again where I hit "Play" on my Grim Dawn in Steam.
    The dialog popped up again doing some "microsoft VC redist package" and "DirectX3d" stuff (Steps 1 through 5). After that I feel I got 0,001 bit closer to getting the game running. This time it didn't close, but steam showed me "Executing" on the game and my cursor disapeared when I moved it into the POL window. My system monitor also showed me my grimdawn.exe. But then nothing more happened even when I let it sit for a few minutes.
    Here's my playonlinux.log I hope this will help. http://pastebin.com/wL21VRuS
    Thanks again a lot for your help and support.
  7. booman
    Of course...
    That is a long log. A lot of steamwebhelper.exe errors, but those do not matter. Shouldn't affect Grim Dawn. It "should" have run, so I'm starting to wonder what kind of hardware you have.
    What video card do you have?
    Did you install proprietary drivers?
    Can you run any other games in PlayOnLinux?
    Grantuu likes this.
  8. Grantuu
    I have a GeForce 940M, I have the proper drivers and PoE works on my system just fine.
  9. dlf
    I think I can pretty much get the game up and running although the title screen won't look like it does in the screenshots and the game appears to freeze when I get into the inventory.
  10. booman
    When it freezes, please post the debug and I'll take a look.

    The only bad symptoms I have been experiencing is missing graphics. Sometimes I go into a dungeon/cave and the floor textures are messed up. I found if you go to the options and change anti-aliasing to x2 or x4, then it fixes the texture.
  11. skweresp
    Hi everyone. I install grim down with steam in wine. Everything was great until last update (11.10.2017) game start freezeing and is unable to play. Is there similar problems with playonlinux installation?
  12. booman
    Welcome to the forum!
    This has happened several times in the past. Grim Dawn does an update and now the game won't run. I've been playing it recently but I'll normally download the entire game and then play offline co-op with my Wife.

    I'll try running the update and see if it gives me any issues as well...

    What distro, Wine version and specs do you have?
    We Grim Dawn working previously?
    It never hurts to try a fresh new install... just don't forge the vcrun2015 manual installation.
  13. skweresp
    @booman Thanks for reply, I use Manjaro Deepin and wine-staging 2.18. I have installed last nvidia drivers and bumblebee. Few minutes I write on this forum I can play for lond time and game don't freeze :) but every new start of game is lottery. Before yesterday update everything was great, no freezeing, no graphics glitches.
  14. booman
    I wonder what the developers updated?
    I'll have to give it a try as well and see if my system is affected too. I'm playing on an older version of wine and have GeForce dedicated video cards:
    • 750 Ti
    • GTX 1060
  15. booman
    I did the update and Grim Dawn runs fine!
    You may want to try re-installing from scratch.
  16. dlf
    Anyone gotten the GOG (/or steam) version to run since the release of the expansion /update? . . . .
  17. booman
    I have the GOG version as well, but haven't picked up the expansion yet.
  18. skweresp
    Thanks, I will reinstall if freezeing will occur.
  19. dlf
    Got steam installed (normal WINE Steam that uses 2.12), and Grim Dawn (post expansion) runs fine, a little more bright then I think it'd be otherwise but that runs. On the other hand trying to get VC2015 run (so I can install either Steam or GOG v) gives when copy+pasting in the last command:

    PlayOnLinux Console

    You are in 's virtual drive environment
    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c > wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
    --2017-10-15 13:53:03-- https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
    Resolving raw.githubusercontent.com (raw.githubusercontent.com)...,,, ...
    Connecting to raw.githubusercontent.com (raw.githubusercontent.com)||:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 700054 (684K) [text/plain]
    Saving to: ‘winetricks’

    winetricks 100%[=====================================>] 683.65K 663KB/s in 1.0s

    2017-10-15 13:53:04 (663 KB/s) - ‘winetricks’ saved [700054/700054]

    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c >
    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c >
    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c > chmod +x winetricks
    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c > WINEPREFIX=/home/dlf/.PlayOnLinux/wineprefix/grimdawn ./winetricks -q vcrun2015
    Using winetricks 20170823-next - sha256sum: 0848eb94dee9ff4393e0fe2d2fcb60796b0bc15a3185a7888716edfa385dcdf9 with wine-2.19 and WINEARCH=win32
    Executing w_do_call vcrun2015
    Executing load_vcrun2015
    Working around wine bug 37781
    This may fail in non-XP mode, see https://bugs.winehq.org/show_bug.cgi?id=37781
    Using native,builtin override for following DLLs: api-ms-win-crt-conio-l1-1-0 api-ms-win-crt-heap-l1-1-0 api-ms-win-crt-locale-l1-1-0 api-ms-win-crt-math-l1-1-0 api-ms-win-crt-runtime-l1-1-0 api-ms-win-crt-stdio-l1-1-0 api-ms-win-crt-time-l1-1-0 atl140 concrt140 msvcp140 msvcr140 ucrtbase vcomp140 vcruntime140
    Executing wine regedit /S C:\windows\Temp\_vcrun2015\override-dll.reg
    Setting Windows version to winxp
    Executing wine regedit /S C:\windows\Temp\_vcrun2015\set-winver.reg
    Running /home/dlf/.PlayOnLinux//wine/linux-x86/2.19/bin//wineserver -w. This will hang until all wine processes in prefix=/home/dlf/.PlayOnLinux/wineprefix/grimdawn terminate
    Executing cd /home/dlf/.cache/winetricks/vcrun2015
    Executing wine vc_redist.x86.exe /q
    wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
    err:wineboot:processRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
    err:module:load_builtin_dll failed to load .so lib for builtin L"winebus.sys": libudev.so.0: cannot open shared object file: No such file or directory
    err:winedevice:async_create_driver failed to create driver L"WineBus": c0000142
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
    err:eek:le:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
    fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
    err:eek:le:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
    fixme:advapi:DecryptFileW (L"C:\\users\\dlf\\Temp\\{74d0e5db-b326-4dae-a6b2-445b9de1836e}\\", 00000000): stub
    fixme:shell:SHAutoComplete stub
    fixme:advapi:DecryptFileW (L"C:\\users\\dlf\\Temp\\{74d0e5db-b326-4dae-a6b2-445b9de1836e}\\", 00000000): stub
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
    p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
    PlayOnLinux: /home/dlf/.PlayOnLinux/wineprefix/GrimDawnGOG/drive_c >

    I've tried (/staging), 2.1.8 (/staging)/2.1.9 and I think I get the same result everytime, I don't think used to (much earlier this year).
  20. booman
    If you can play Grim Dawn then you installed vcrun2015 just fine. I know its confusing and I hope PlayOnLinux developers can add it to the packages list some day.

    I'm not sure what the "winemenubuilder" errors are all about. I don't remember seeing those when I installed vcrun2015. Make sure to kill all processes in that virtual drive before installing vcrun2015

    I don't have the expansion yet so I can't test it either.

Share This Page