1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Age Of Wushu Guide

Discussion in 'Guides' started by booman, Aug 8, 2014.

  • by booman, Aug 8, 2014 at 1:44 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,291
    Likes Received:
    615
    Trophy Points:
    113
    Location:
    Linux, Virginia
    Home page:
    Everything you want from Anime in a single game! Age of Wushu is a massive online multiplayer RPG with loads of character development, massive environments and classic Kung Fu moves all in Ancient China. Spend hours building up skills, exploring or socializing with NCP's and PVP characters.

    wushu85.png

    wushu87.png

    Follow my step-by-step guide on installing, configuring and optimizing Age of Wushu in Linux with PlayOnLinux.

    Note: This guide applies to the Snail Games version of Age of Wushu. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    int 17 64-bit
    PlayOnLinux: 4.2.4
    Wine: 1.5.19

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.5.19
    Note: Try using stable Wine 1.8 and 1.8-staging
    Select it
    Click the arrow pointing to the right

    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Downloading Gecko
    wine05.png


    Installed
    wine06.png

    Wine 1.5.19 is installed and you can close this window

    Age of Wushu Downloader

    Go to: www.ageofwushu.com
    Click Download
    wushu01.png

    Download full game by clicking "Click here to download"
    Or Download separate .cab files to a folder on your desktop
    wushu02.png

    Save Ageofwushu_download.exe to your desktop
    wushu04.png

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    wushu05.png

    Click "Install a non-listed program"
    wushu06.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    wushu08.png

    Name your virtual drive: ageofwushu
    Click Next
    wushu09.png

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries

    Click Next
    wushu10.png

    Select Wine 1.5.19
    Click Next

    Select "32 bits windows installation"
    Click Next
    wushu13.png

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply
    wushu14.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop Size: Set to match the resolution of your Linux desktop
    Click OK
    wushu15.png

    Installing Components (Libraries/Packages/DLL's)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_physx
    • POL_Install_registered_fonts
    • POL_Install_tahoma
    • POL_Install_wininet
    • POL_Install_xact
    Click Next
    Note: All libraries will automatically download and install

    Installing Age Of Wushu

    Click Browse
    wushu16.png

    Navigate to your desktop
    Select "AgeofWushu_download.exe"
    Click Open
    wushu17.png

    Click Next

    Age of Wushu launcher will run
    Click Start to begin downloading (10 GB)
    wushu19.png

    Downloading...
    wushu20.png

    Installing Age of Wushu

    Click Next

    Select "I accept the terms..."
    Click Next

    click Next

    Click Install

    Installing

    Uncheck "Launch Now"
    Click Finish
    wushu26.png

    PlayOnLinux Shortcut

    Select "fxlaunch.exe"
    Click Next
    wushu27.png

    Name your shortcut: Age Of Wushu
    Click Next
    wushu28.png

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Age Of Wushu"
    Click Configure
    wushu29.png

    General Tab
    Wine Version: 1.5.19
    wushu30.png

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    Video Memory size: Select the amount of memory your video card/chip uses
    wushu31.png

    Close Configure

    Launching Age of Wushu

    Back to PlayOnLinux
    Select Age of Wushu
    Click Run
    wushu32.png

    Note: Click Debug to see console errors and bugs

    Click Confirm
    wushu33.png

    Select a server
    Click Confirm
    wushu34.png

    Updating/Settings

    After selecting a server Age of Wushu will probably download an update
    wushu35.png

    Click Settings
    • Uncheck Windowed Mode for fullscreen
    • Adjust Resolution
    • Adjust volumes
    wushu36.png

    Click Play
    wushu37.png

    Loading...
    wushu38.png

    Login
    Click Enter Game
    wushu39.png

    Select Character
    wushu40.png

    Optimization

    Press Esc in-game
    Click Video Options
    wushu41.png

    Use presets on the left
    Or
    Adjust settings manually
    wushu42.png

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    The Video Options has a great Frame Counter.
    As you increase the settings watch the frame rate.
    Anything below 20 will stutter a lot.

    Conclusion:
    I originally tested Age of Wushu with Wine 1.6.2 and newer version, but kept getting a pop-up error "Speed Up" and it was very annoying. Luckily I found Wine 1.5.19 runs perfectly!
    Also, the game refuses to do high resolutions unless you set the virtual desktop first. So I set mine for 1680x1050 and it played fullscreen just fine. What a beautiful game! I was able to crank the depth of view really high on my GeForce 550 Ti and see mountains and buildings really far away.

    Gameplay Video


    Screenshots:
    wushu100.png

    wushu99.png

    wushu98.png

    wushu95.png

    wushu92.png

    wushu88.png

    wushu81.png
    Last edited: Apr 24, 2016

Comments

Discussion in 'Guides' started by booman, Aug 8, 2014.

  1. Zergling_man
    Cool, thanks for that; it won't fix that wine can't detect it when I'm setting up the virtual drive, but when I finally reach the point of installing Wushu, that might save me a headache or two.
    booman likes this.
  2. Dimebag
    @booman Just back to say that I installed Mint and game seems to work :)

    BUT

    EXTREMELY slow. It took 6mins (on the clock) to get to the login page, and I've been stuck on entering game for 10mins now. Any ideas why?

    Info:
    Nvidia is on (nvidia-settings works, it shows my card, it also shows in the bottom right of screen)
    bumblebee & primus are installed successfully (can use optirun with no error)
    While the game (launch) is running through terminal, I get 1 error = failed request: GLXBadDrawable. Maybe this is why it's slow?

    I'm going to try with optirun and/or with Wine 1.7.47, maybe this fixes it. I'm waiting first to get inside the game to make sure it's on minimum settings. Still not loaded after this comment LOL
  3. Dimebag
    update: I know for certain the game CAN load immediately on the laptop because it worked while I was on win7. It has to be some configuration thing
  4. Dimebag
    Update:
    It now works fine. Wow. I'm just speechless. No more 30min to load the game. I haven't changed anything, just started again. Maybe just the first load ever of the game that takes ages?

    Side notes:
    - I tried using optirun vs not using it on both intel and nvidia selected through nvidia-settings (so 4 combinations in total). Conclusion is that optirun doesn't seem to do anything. I mean running something with optirun or not produces the same results. It "starts" also when intel is selected.
    - Changing between intel and nvidia is visible (and works) only through nvidia-settings. The gpu is indeed turned off when intel is selected, according to optirun --status.
    - Also did a PC shutdown to rule out the 30min-load being a per-boot process. It still worked fine, i.e. fast, on reboot.

    I am overall slightly confused about the entire behavior; will have to check how much the battery lasts and so on but nevertheless, IT F*** WORKS
  5. booman
    Yes that is very confusing....
    It's hard to know what is going on behind the scenes, so watching the terminal or PlayOnLinux debug is the only way.
    I don't particularly remember a long startup process with Age of Wushu

    Exactly which screen were you stuck at?
    I noted that I was getting a pop-up error stating "Speed Up" with older versions of Wine...
    I haven't tested Age of Wushu with newer versions like: 1.7.55-staging or 1.8-rc4
  6. Dimebag
    Basically everything was in slow motion; where I mentioned 6min is at the screen that follows after clicking "start game", where a loading bar is supposed to popup at the bottom. I was stuck before that bar showed up. Then (still slow overall), I waited more than 10min for my char to load at the screen after you type username/password; stuck after I pressed "enter game" but before map and in-game interface showed up.

    For settings I used everything as in your guide, so the older Wine version. Haven't gotten to trying a newer one since it works perfectly now.

    I still don't know why optirun doesn't do anything but I don't really care anymore lol
  7. booman
    Ok, at least its working. If I had experienced those symptoms when I did first run, I would have noted it. Very strange.
  8. Dimebag
    @booman Hey, I'm back. Game doesn't start since last patch update -_- I'm stuck again at the same screen before the loading bar, as explained in post #46. Also tried using the latest wine to no success and both the landscape and the old login interfaces (it asks you to choose when starting game since last patch).

    Any chance you could take a look at it, maybe one needs a new/extra pack for the game to work?

    I'm thinking it's because of the 'new' Snail Game Protect which should launch at the exact moment the game gets stuck (and it looks like it doesn't). Just a reminder, I'm talking about the EU AOW with the latest patch being ch8.
  9. booman
    Welcome back Dimebag. I can take a look at it. I hate it when a patch breaks a game. did you search WineHQ's as well? It appears they have changed the anti-cheat program. It used to be called GPK "Game Protection Kit"

    Did you download the NEW installer 0.0.1.175 in individual pieces?

    I started downloading the individual .cab files this morning. I got half of them and will finish the next half tomorrow morning
  10. Dimebag
    @booman Well I googled around and I see people saying the guard system is impossible to use in a virtual machine because it's some sort of 'root' program(?); but then I also see others saying to try harder or try virtualbox

    What I did is simply let the launcher update itself. I believe the 0.0.1.175 you're referring to is the US AOW, not the EU which is at 0.0.1.074. They should have the same guard system but the US version is ahead with the patches, therefore the solution might not be the same for EU now.
  11. booman
    Oh, interesting... I don't understand why a free-to-play game needs DRM
    would you like me to continue downloading and test it again?
  12. Dimebag
    yes, of course. I need any help in making it work again xD if it's possible.

    i could try things too, but i don't know what
  13. booman
    I'm finished with downloading the US game. I really don't want to start over with EU game, so I'll go ahead and install, then report back my findings.
  14. booman
    I was able to open the client and do a quick update
    After clicking Start I got this error:
    Code:
    Failed to load drivers, please try to run them as administrator
    And then:
    Code:
    SGP Initialize failed
    I also saw a lot of these errors in the debug:
    Code:
    err:winediag:IcmpCreateFile Failed to use ICMP (network ping), this requires special permissions.
    If you don't install Registered Fonts you will see this initially:
    ageofwushu_nofonts.png
  15. booman
    got a little further, was able to see the main screen but I noticed a little pop-up with a Exclamation point and says Snail Games Protect

    Also a lot of these in the debug:
    Code:
    fixme:virtual:__syscall_NtQueryVirtualMemory (process=0x234,addr=0xec690000) Unimplemented information class: MemorySectionName
    ITS WORKING!
  16. Dimebag
    So you did everything exactly the same as basically 2 years ago? Same wine version, same installed packs, etc?
  17. booman
    Almost, same steps but I used Wine 1.8 and had to add the package: POL_Install_RegiersteredFonts

    It errored the above error a few times but when I switched to Windows XP in Wine Configuration it worked. Took a few minutes to load up first time, but it worked.

    I used the US installer as mentioned before.
  18. Dimebag
    So how exactly did you get past the screen with red '????' ?

    I re-downloaded latest installer and I get that screen and it's stuck; whatever I click, it ends. Was using the exact same Wine and settings as in this guide; also tried Wine 1.8.

    Note that "POL_Install_registered_fonts" does not exist; I only chose POL_Install_RegisteredFonts instead and still get that screen. Are you sure you didn't do anything different?
  19. booman
    Dang I thought "RegisteredFonts" was the packaged that did it...
    I switched between Wine 1.8 and Wine 1.8-staging and then changed the Windows version to Windows XP in Wine Configuration.
  20. Dimebag
    Wine 1.8, 1.8-staging, 1.9.7, 1.5.19 (all x86)
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_physx
    • POL_Install_RegisteredFonts
    • POL_Install_tahoma
    • POL_Install_wininet
    • POL_Install_xact
    Windows XP, with graphics setup as in the guide

    => still stuck when installing in that screen with red ????

Share This Page