1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Age Of Wushu Guide

Discussion in 'Guides' started by booman, Aug 8, 2014.

  • by booman, Aug 8, 2014 at 1:44 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,291
    Likes Received:
    615
    Trophy Points:
    113
    Location:
    Linux, Virginia
    Home page:
    Everything you want from Anime in a single game! Age of Wushu is a massive online multiplayer RPG with loads of character development, massive environments and classic Kung Fu moves all in Ancient China. Spend hours building up skills, exploring or socializing with NCP's and PVP characters.

    wushu85.png

    wushu87.png

    Follow my step-by-step guide on installing, configuring and optimizing Age of Wushu in Linux with PlayOnLinux.

    Note: This guide applies to the Snail Games version of Age of Wushu. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    int 17 64-bit
    PlayOnLinux: 4.2.4
    Wine: 1.5.19

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.5.19
    Note: Try using stable Wine 1.8 and 1.8-staging
    Select it
    Click the arrow pointing to the right

    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Downloading Gecko
    wine05.png


    Installed
    wine06.png

    Wine 1.5.19 is installed and you can close this window

    Age of Wushu Downloader

    Go to: www.ageofwushu.com
    Click Download
    wushu01.png

    Download full game by clicking "Click here to download"
    Or Download separate .cab files to a folder on your desktop
    wushu02.png

    Save Ageofwushu_download.exe to your desktop
    wushu04.png

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    wushu05.png

    Click "Install a non-listed program"
    wushu06.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    wushu08.png

    Name your virtual drive: ageofwushu
    Click Next
    wushu09.png

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries

    Click Next
    wushu10.png

    Select Wine 1.5.19
    Click Next

    Select "32 bits windows installation"
    Click Next
    wushu13.png

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply
    wushu14.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop Size: Set to match the resolution of your Linux desktop
    Click OK
    wushu15.png

    Installing Components (Libraries/Packages/DLL's)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_physx
    • POL_Install_registered_fonts
    • POL_Install_tahoma
    • POL_Install_wininet
    • POL_Install_xact
    Click Next
    Note: All libraries will automatically download and install

    Installing Age Of Wushu

    Click Browse
    wushu16.png

    Navigate to your desktop
    Select "AgeofWushu_download.exe"
    Click Open
    wushu17.png

    Click Next

    Age of Wushu launcher will run
    Click Start to begin downloading (10 GB)
    wushu19.png

    Downloading...
    wushu20.png

    Installing Age of Wushu

    Click Next

    Select "I accept the terms..."
    Click Next

    click Next

    Click Install

    Installing

    Uncheck "Launch Now"
    Click Finish
    wushu26.png

    PlayOnLinux Shortcut

    Select "fxlaunch.exe"
    Click Next
    wushu27.png

    Name your shortcut: Age Of Wushu
    Click Next
    wushu28.png

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Age Of Wushu"
    Click Configure
    wushu29.png

    General Tab
    Wine Version: 1.5.19
    wushu30.png

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    Video Memory size: Select the amount of memory your video card/chip uses
    wushu31.png

    Close Configure

    Launching Age of Wushu

    Back to PlayOnLinux
    Select Age of Wushu
    Click Run
    wushu32.png

    Note: Click Debug to see console errors and bugs

    Click Confirm
    wushu33.png

    Select a server
    Click Confirm
    wushu34.png

    Updating/Settings

    After selecting a server Age of Wushu will probably download an update
    wushu35.png

    Click Settings
    • Uncheck Windowed Mode for fullscreen
    • Adjust Resolution
    • Adjust volumes
    wushu36.png

    Click Play
    wushu37.png

    Loading...
    wushu38.png

    Login
    Click Enter Game
    wushu39.png

    Select Character
    wushu40.png

    Optimization

    Press Esc in-game
    Click Video Options
    wushu41.png

    Use presets on the left
    Or
    Adjust settings manually
    wushu42.png

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    The Video Options has a great Frame Counter.
    As you increase the settings watch the frame rate.
    Anything below 20 will stutter a lot.

    Conclusion:
    I originally tested Age of Wushu with Wine 1.6.2 and newer version, but kept getting a pop-up error "Speed Up" and it was very annoying. Luckily I found Wine 1.5.19 runs perfectly!
    Also, the game refuses to do high resolutions unless you set the virtual desktop first. So I set mine for 1680x1050 and it played fullscreen just fine. What a beautiful game! I was able to crank the depth of view really high on my GeForce 550 Ti and see mountains and buildings really far away.

    Gameplay Video


    Screenshots:
    wushu100.png

    wushu99.png

    wushu98.png

    wushu95.png

    wushu92.png

    wushu88.png

    wushu81.png
    Last edited: Apr 24, 2016

Comments

Discussion in 'Guides' started by booman, Aug 8, 2014.

  1. Zergling_man
    (Hey Dime, Qini here.)

    Alright, so I'm trying to get this working. One side-question is "can I just copy the installed Wushu from my games drive to the virtual drive" (and better yet, can I move the virtual drive to my games drive...), but the main question is:
    I can't get the config stuff to work. I have yet to reach a point where I can see the wine configuration. During initial setup of the virtual drive it skips it, if I try to get to config after it just kills itself.

    OS is Debian Jessie/SteamOS Brewmaster, mostly fresh install/dual-boot.
  2. Zergling_man
    EDIT: Also looking in the logs, wine complains about not being able to access TrueFont and suggests I install FreeType. According to the package lists, I should have it installed. I'm going ahead and trying to install it, regardless. I'll see what errors are left after this.
  3. Zergling_man
    EDIT2: Okay so back to the drawing board. I get the incredibly unhelpful error "Error in POL_Wine
    Wine seems to have crashed

    If your program is running, just ignore this message" when I try to run this with system version of wine (1.6.2).

    This does not occur when using the last 1.6.2 specifically (scumvm support). Instead it hangs at 'creating virtual drive'.
  4. vashin
    Nice post. Thank you, I just got Jade Empire working through Origin. I may give this a go.
    booman likes this.
  5. booman
    This will be a trial-n-error
    Some client allow you to copy the entire game folder from one OS to another... or from one hard drive to another. Steam will automatically discover the new files instead of re-downloading them. Other clients like ARC won't see the game files and downloads the game all over again to a different directory.

    So I'm not totally sure with Age of Wushu. Try it and see what happens. Just make sure to get the client (updater) installed in the virtual drive first. You may even have to start downloading the game to know where the game files are suppose to reside.

    I also recommend using a newer version of Wine: 1.7.55-staging
    I haven't tested Age of Wushu in this version, but chances are it will run fine.

    If you still get errors, please run the client/game by clicking Debug instead of "Run"
    Then post the output in our PlayOnLinux forum as a new post:
    http://www.gamersonlinux.com/forum/forums/playonlinux.9/
  6. booman
    I noticed Jade Empire was free on Origin too... I already have it on GOG
    Age of Wushu is much better and open world. Jade Empire is cool, but has some horrible game decision like the stupid flying minigame.
    vashin likes this.
  7. Zergling_man
    I wish to clarify here that I am using SteamOS, not Steam as such. In other words, Debian with a twist. My attempts to get Wushu running will be completely ignoring the Steam portion of things.

    See here's the problem. My POL - or wine, I'm not sure which - are just flat up broken. I can't even get to the point of installing Wushu, letalone testing it. I've been looking around for this more basic error - and for some reason results from the forum didn't show up. I'll search there specifically.
  8. booman
    oh, I had no idea you were in SteamOS. This is new ground you are treading...
    I am not familiar with the changes to Debian Valve has made. I have yet to read a tutorial on how to install Wine, PlayOnLinux and games in SteamOS.

    A few things are required for Linux in general:
    1. Proprietary Drivers (Nvidia for best performance)
    2. 32-bit libraries (32ia-libs or multiarch)
    3. Wine Installed
    4. PlayOnLinux Installed (Might require xterm & microsoft fonts)
    5. PlayOnLinux packages (d3dx9, tahoma, dotnet, etc)
    If any of these are a mystery on SteamOS, then we might have some problems. I think I have read some gamers were able to install Wine and some PC games in SteamOS.
  9. Zergling_man
    Well some of them are a mystery to me. I've been assured that SteamOS will be automagically installing proprietary drivers, and I'm happy to assume it has correctly identified my AMD card and not installed Nvidia drivers. This said, I will try and find out how to confirm this. (Hmm, this seems somewhat relevant, but it doesn't help me prove it for my specific system.)

    The 32-bit libraries... I assume you've listed some packages there, so I'll be attempting to install those. I'll -also- be installing wine first this time.
    (Oh yes, it's worth noting that in my attempt to make xfce work, I completely ruined my system and hence reinstalled.)

    Now, regarding xterm and Microsoft fonts... I actually use xterm as my primary terminal app because the normal one doesn't work - and I'm assuming that's a SteamOS special. Microsoft fonts, on the other hand, I refer back to the weird error regarding FreeType fonts. And I just confirmed, after a (mostly) fresh install, I have libfreetype6-2.5.2 installed.
    Regarding POL packages, they're supposed to be installed per virtual drive during the setup process, right? That part worked for me - unlike configuring wine.

    I've also been supported by a long-term Linux friend of mine, who recommends winetricks instead of POL. What are your thoughts on this?
  10. booman
    PlayOnLinux will error about xterm when I just installed a fresh copy of Mint. I use Synaptics Package Manager to install xterm.
    Microsoft Fonts are installed automatically by PlayOnLinux when you setup your first virtual drive.

    Winetricks is good, but PlayOnLinux goes a step further
    PlayOnLinux has a LOT more available Windows libraries for games and patched versions of Wine. Winetricks will not support them.
    When I started Linux gaming I initially used Winetricks but quickly found that it was missing a lot of options. I'm sure there are a lot more now, but PlayOnLinux does it all for me.

    Some of your problems may be related to the AMD video card. I'm sure you have heard that AMD drivers can cause a lot of performance issues. You can use open source drivers, but some games might not run at all.

    All of my success with games is due to Nvidia drivers, PlayOnLinux and a lot of patience.
    vashin likes this.
  11. vashin
    It gets fun when you have Wine installed some games on 32 bit prefixes others on 64 and playonlinux 32 bit and 64 switching back and fourth between prefixes can be entertaining at times.. Best to keep it simple.. Even though I don't lol..
  12. booman
    I'm avoiding 64-bit virtual drives until I really have time to test it or more reports of success appear.
    i've always had good results with 32-bit.
    vashin likes this.
  13. Zergling_man
    We... Are talking about the same "xterm", right? The very simple terminal? That comes preinstalled on SteamOS?
    I haven't seen POL generate a specific error about it as yet.

    Ah, okay, so the freetype stuff is completely unrelated. Whelp. Why is wine giving me errors about that then? ~_~

    Ah, quite possibly... I'll investigate this.
  14. Zergling_man
    Some derping and poking later, I think I've worked out why the config doesn't work, and it seems to be "because 64-bit".
    Trying to run winecfg from terminal gives me an error about not being able to find winecfg.exe. Turns out it's a link to wine-wrapper which does the same thing. At any rate, this bug report addresses it.

    "It's already fixed in the
    wine-development packages since 1.7.14-4."
    Now to figure out why it doesn't work in POL with 1.8-rc3.
  15. booman
    Every time I have installed PlayOnLinux in a fresh Mint installation, I get a warning that "xterm" needs to be installed. not sure why, but after installing it, everything works fine.

    I suggest using a 32-bit version of Wine and a 32-bit virtual drive. I'm not even sure if Age of Wushu is 64-bit compatible anyways???

    I don't remember getting font errors for any game so far...
    That last time I've heard of Font errors is with EverQuest II mentioned here:
    http://www.gamersonlinux.com/forum/threads/everquest-ii.661/
  16. Zergling_man
    Huh. Well if that problem does exist on Debian, I skip it by having xterm preinstalled. (... I don't know why terminal doesn't work though.)

    It's not. And I /am/ using a 32-bit version of wine and 32-bit virtual drive. System wine has the problem because winecfg links to a 32-bit exe that doesn't exist on a 64-bit *system*.

    This also refers to the previous paragraph: I iterate *again* that I have yet to actually attempt installing a game. All of the errors I've got so far have been in setting up the virtual drive and trying to configure wine. Ergo, these errors will occur with any game, because they happen before ANY game-specific stuff.
    I have a problem with wine not detecting freetype, full stop.
  17. Zergling_man
    EDIT: with POL's wine not detecting freetype*
    Also, it suddenly hit me that that's probably -also- a 64-bit thing.
  18. booman
    Could be, you can always try re-downloading Wine and PlayOnLinux again.
    I'm not aware of Arch and how it handles libraries. So I am of no help there
    Please let me know if you get it worked out.
  19. Zergling_man
    Hmm, I'm poking this again. Not necessarily hoping to achieve anything more, just to find any errors I may have missed, such as:

    Error in source
    Error 3 registering DLL /home/desktop/.PlayOnLinux//wineprefix/wushu/drive_c/windows/system32/xaudio2_7.dll

    Every other component installs fine. I refuse to believe this one is a 64-bit issue...
  20. booman
    Found a couple of interesting font-related tips on WineHQs:
    Definitely try that -no-dwrite tip
    I've used it for a long time with Steam because there would be no fonts at all when launching Steam.
    You can add the command -no-dwrite in Arguments in PlayOnLinux Configure like this:
    -no-dwrite.png
    Just select your Age of Wushu shortcut on the left, then type the command next to Arguments
    vashin likes this.

Share This Page