1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Neverwinter Free MMO Guide

Discussion in 'Guides' started by booman, Jul 2, 2013.

  • by booman, Jul 2, 2013 at 2:32 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Virginia
    Home page:

    There are already a lot of Dungeons & Dragons games out there. From board games to card games and video games. The Lore of D&D is nothing new to most of us...
    But I am excited to see Neverwinter appear as a Free game with the ability to use everything available in the game without having to spend a penny. The graphics are beautiful, the the world is huge, fight along side friends, customize your character and all the rest of the expected RPG qualities.


    Follow my step-by-step guide on installing, configuring and optimizing Neverwinter in Linux with PlayOnLinux.

    Note: This guide applies to the downloadable version of Neverwinter. Steam and Arc versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Note: March 2017 Perfect World Entertainment ended support for Windows XP and Direct X 9. This guide no longer applies until we can pursue more testing in Wine.

    Mint 17 64-bit
    PlayOnLinux: 4.2.8
    Wine: 1.7.40

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.7.40
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.7.40 is installed and you can close this window

    Download the Neverwinter installer here:

    Save in a folder on your desktop

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install

    Click "Install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name the virtual drive: neverwinter
    Click Next

    Check all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine 1.7.40
    Click Next

    Select "32 bits windows installation"
    Click Next

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1024x768
    Click OK

    PlayOnLinux Packages (Libraries, Components, DLL's)

    Check the following packages:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    Click Next

    Note: All packages will automatically download and install

    Installing Neverwinter

    Click Browse

    Navigate to the folder on your desktop
    Select "neverwinter_setup.exe"
    Click Open

    Click Next again

    Select language
    Click OK

    Click Next

    Click "I Agree"

    Click Next

    Uncheck "Create a desktop icon"
    Click Install

    Uncheck "Launch Neverwinter"
    Click Finish

    PlayOnLinux Shortcut

    Select "Neverwinter.exe"
    Click Next

    Name your shortcut: Neverwinter
    Click Next

    Select "I don't want to make another shortcut"
    Click Next

    PlayOnLinux Configure

    Select Neverwinter
    Click Configure

    General Tab
    Wine version: 1.7.40

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine

    Display Tab
    Video memory size: Enter the amount of memory your video card/chip uses

    Close Configure

    Launching Neverwinter

    Select Neverwinter
    Click Run

    Login with your account credentials

    Neverwinter will begin downloading and patching
    In total the game is about 13 Gigabytes

    Note: This process can take several hours depending on your internet speed

    When its done downloading click PLAY

    Long Cryptic loading screen
    At first launch, this Cryptic screen can literally take 15-20 minutes
    Please be patient and take a break

    Sometimes the login will fail and end up at this login screen
    Enter your account credentials
    Click LOGIN

    Once in game, select your character
    Click Enter World


    Click Options
    Click Graphics Tab

    Adjust resolution to match your Linux desktop

    • Screen
    • Detail
    • Effects
    • Lights

    Use the Render Quality (Video Card) and Graphics Detail (CPU) sliders

    Go to the Advanced tab for more settings
    Click OK or Apply

    Note: When in-game, settings will automatically change on the screen

    Neverwinter runs extremely well on my Geforce 550 Ti. I can turn almost all the graphical settings to high and still get a decent frame rate. This game is beautiful for an Online MMO and its best to play on a desktop with a modern graphics card.
    Normally when I first Enter World, there is a bit of lag as the level loads.

    Gameplay Video:









    Last edited: Apr 3, 2017


Discussion in 'Guides' started by booman, Jul 2, 2013.

  1. Angela
    That's the thing. It's not there. It spends all that time downloading and the folder is empty when it's done. Phantom files are phantom.

    Anywho... I'm going to try Steam. The reason why I forwent that option to begin with is because it disappeared from Steam for a time when I had stopped playing on Windows in favor of their Arc installer. I guess it made it back into the Steam repository.

    I'll try that method instead and get back to you on whether it works or not.
  2. booman
    I'll give it a go this weekend and see if I get the same symptoms.
    Something is going wrong with the downloader.
    You could always try a different game like Star Trek, Champions or Swordsman.
    All big downloads of course :(
  3. booman
    I keep forgetting to work on this... I still have a reminder in my inbox, bare with me
    I will get started on this tonight or in the morning... I hope ;)
  4. randym
    Just an FYI, I have both Neverwinter and STO running through a Steam install with no extra config stuff. There were a couple of hiccups, hangs, and crashes on the install, but I just restarted the process and it eventually finished. The games run pretty good on my older system [i7/920, 9GB RAM, GTX-260, Toshiba SSD].
  5. booman
    Ah, ok, so maybe Arc just needs to refresh.
    If I remember correctly, Neverwinter will download to a temporary directory first, then when its done, it transfers to the Arc Games folder.
  6. randym
    When I installed it through Steam it didn't install Arc. When launched from Steam it goes straight to the Cryptic launcher.
  7. booman
    I installed Arc and downloaded the entire game last night. Tried it this morning and it hung for a bit at "Loading..."
    So I restarted Arc and launched Neverwinter again. Waited about 10 minutes and it finally launched.
    I even made a video.

    Angela - Let me know if Steam doesn't work for you. If this is the case, maybe its a driver issue or a library.
  8. linuxnoob
    I was so happy when I ran into this guide. I had for a long time considered breathing new life into my old laptop, and this finally sealed the deal. Now the laptop has LXLE, with which I have pretty much no idea what to do.

    Looking at the pretty pictures I got POL and Wine sorted, and even Arc was working just fine.

    But the game itself just will not finish loading. The "Cryptic" loading screen seems to be actually getting faster, but the calibration screen just flashes there, before the client moves to the "Neverwinter" loading screen. And then crashes.

    Aaand just as it should be, as I was writing this it just started making the game sounds behind me. Figures.

    But what made it work this time? In some other guide a person suggested to turn off on-demand patching and turn on safe mode in the Neverwinter client options before launching the game. This way I atleast got it running the first time, and second time was able to run in non-safe mode.

    No idea if this will help anyone, but thought I'd add it here as the most recent experience.

    Wine 1.7.10 btw, if it matters.

    Thank you for the guide, it got me on the right way at the very least, probably much more than that :)
  9. allenskd
    I think what plagues the game is the insane patching time. If there's a big patch of 600-800mb that thing take ages to patch, like 20-30minutes waiting for the screen to go away :(
  10. booman
    Yes the patching is big, but Linuxnoob is right, the initial loading of neverwinter at the Cryptic screen can take at least 15 minutes. It doesn't happen every time, but its very misleading and makes you think the game isn't working.
    I have not tried turning off "on-demand patching" or turning on "safe mode".
    I will have to load up my wineprefix and see what it does.
    I have not heard elsewhere if those changes can make any differences
  11. allenskd
    Also turn off WINEDEBUG and it impede any sort of progress as it's a constant flood of text. It blocks any progress
  12. ViperZ
    Hey booman I am having trouble getting the game to load properly under Ubuntu 14.04 64bit as they stripped the lib 32 stuff out. Any chance to you could help me get that squarred away? I worked on it but with no success so far. Hope to hear from you. Thanks.
  13. booman
    Try one of these commands:

    Ubuntu 14 32-bit libraries:
    sudo dpkg --add-architecture i386
    sudo apt-get update
    sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
    Or Ubuntu 32-bit Instructions:
    sudo dpkg --add-architecture i386; sudo apt-get update
    sudo apt-get install libasound2:i386 libasound2-plugins:i386 libfontconfig1:i386 lib32nss-mdns libgnutls26:i386 libxslt1.1:i386 libxcursor1:i386 libxcomposite1:i386 libosmesa6:i386 libopenal1:i386 libmpg123-0:i386 libldap-2.4-2:i386 liblcms2-2:i386 libgstreamer0.10-0:i386 libgstreamer-plugins-base0.10-0:i386 libgsm1:i386 libxinerama1:i386 libxi6:i386 libv4l-0:i386 libsane:i386 libudev1:i386 libxml2:i386 libcups2:i386 libxrandr2:i386 libice6:i386 libsm6:i386
  14. ViperZ
    Booman - none of those made any difference.

    I get to the login screen of the game and login however when I click Play that is when Cryptic crashes. I had updated to nvidia proprietary drivers instead of the xserver default drivers.

    I was working with someone in the PlayOnLinux IRC channel and he says because Ubuntu 14.04 64 bit has removed the 32 bit libraries.

    Thanks for your help and let me know if you have any other suggestions.
  15. booman
    Did you restart after installing these 32-bit libraries?
    Yes Ubuntu removed the simple package ia32-libs, but running the command above installs all the libraries you would typically need.
    If you use Linux Mint, they still support the ia32-libs package and it does everything for you
  16. ViperZ
    Yes I rebooted. There my research on Linux a couple years back when I was looking to get back into Linux the rave was all about Ubuntu. My goal is a complete move away from MS and was looking for the most friendliest flavor of Linux to run windows products, namely games. I guess if I went Ubuntu 32 bit I wouldnt be having this problem.
  17. booman
    The problem might be related to video drivers and hardware instead of the 32-bit libraries. One way to test the 32-bit libraries is to play an older game. Most games aren't even 64-bit compatible.
    Try one of our guides that shows you how to install a free game like Drakensang or Spiral Knights. If they run perfectly, then its probably something to do with Neverwinter or your video card drivers.
    Which video card/chip are you using?
  18. ViperZ
    It was using an xserver ver of video drivers which the intro screen and other things didnt look right. I have an nVidia GT 630 with an i5 processor and 6 gig of ram. I switched to the proprietary tested driver - ver 346.82 and that cleared up all the video issues however Neverwinter doesnt run. Now with the xserver driver I did get into the game however it was so laggy that it was unplayable. Now when I ran the sudo apt-get update command it updated a lot of stuff but towards the bottom here is the output:

    Err http://archive.ubuntu.com raring/main amd64 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/restricted amd64 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/universe amd64 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/multiverse amd64 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/main i386 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/restricted i386 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/universe i386 Packages
    404 Not Found [IP: 80]
    Err http://archive.ubuntu.com raring/multiverse i386 Packages
    404 Not Found [IP: 80]
    Ign http://archive.ubuntu.com raring/main Translation-en_US
    Ign http://archive.ubuntu.com raring/main Translation-en
    Ign http://archive.ubuntu.com raring/multiverse Translation-en_US
    Ign http://archive.ubuntu.com raring/multiverse Translation-en
    Ign http://archive.ubuntu.com raring/restricted Translation-en_US
    Ign http://archive.ubuntu.com raring/restricted Translation-en
    Ign http://archive.ubuntu.com raring/universe Translation-en_US
    Ign http://archive.ubuntu.com raring/universe Translation-en
    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/main/binary-amd64/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/restricted/binary-amd64/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/universe/binary-amd64/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/multiverse/binary-amd64/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/main/binary-i386/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/restricted/binary-i386/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/universe/binary-i386/Packages 404 Not Found [IP: 80]

    W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/multiverse/binary-i386/Packages 404 Not Found [IP: 80]

    E: Some index files failed to download. They have been ignored, or old ones used instead.

    So I am not sure if I have what I need installed. I will look up one of those guides and see if the game loads as you have asked. I will let you know once I have done that and hopefully we can get this resolved. Thanks for your help!
  19. ViperZ
    Ubuntu does not know how to handle the Spiral Knights .bin file (not sure why) and on Drakensang it downloads a file with the extension .dmg and so I couldnt do that one either. Just updating you.

Share This Page