1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No login possible after sudo in Mint

Discussion in 'Crashed!' started by cloasters, Mar 12, 2016.

  1. cloasters

    cloasters Well-Known Member

    Joined:
    Jul 3, 2013
    Messages:
    3,099
    Likes Received:
    53
    Trophy Points:
    48
    Thanks for the assistance! Can't figure out how to cut and paste the terminal window. After typing su then ENTER it asks for password. Typed it in and hit ENTER:
    "contracted first and last name then first name-last name #" is the reply.

    "Contracted" means shortened name in this case. Thank you!
    Last edited: Mar 15, 2016
  2. cloasters

    cloasters Well-Known Member

    Joined:
    Jul 3, 2013
    Messages:
    3,099
    Likes Received:
    53
    Trophy Points:
    48
    Maybe this will help? After I close Chrome I get a window with "Unlocking Login Keyring" above it. In the window
    I see: "The login keyring did not get unlocked when you logged into your computer."
    Then there is a box to type in "Password:"

    Right underneath that are two mini-box choices: "Cancel" and "Unlock."
    I hit "Cancel" because I don't really know what this window means.
  3. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,073
    Likes Received:
    117
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    Have you tried entering your password and then clicking "unlock"?
  4. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,073
    Likes Received:
    117
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
  5. cloasters

    cloasters Well-Known Member

    Joined:
    Jul 3, 2013
    Messages:
    3,099
    Likes Received:
    53
    Trophy Points:
    48
    Thank you for your help, Gizmo! Candidly, I'm a-scared to enter my password and choose "Unlock." What if I lock myself out?
  6. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    George, I'd still like to know what you were trying to run with 'sudo'. Is it a secret?

    Next, please show us the output of this:

    Code:
    ls ~/.gnome2/keyrings/
    or, look at the contents of ~/.gnome2 in your file manager, and tell me if there is a directory called 'keyrings'

    also:
    Code:
    ls ~/.local/share/keyrings/
    please. Likewise, you can look at ~/.local/share in your file manager and tell me if a 'keyrings' directory exists.

    [In case you don't know, '~' is shorthand for '/home/yourusername/'. So '~/.local/share/' is the same as '/home/thunderrd/.local/share' for me]
  7. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    This is all related to a password to unlock the gnome keyring, which isn't really necessary if you're the sole user. Somehow, it appears that you've inadvertently set it. Don't worry, we'll make the problem go away.

    @booman: is there some kind of a proprietary Mint frontend for gnupg? The only one I've used before [rarely] is seahorse, but I'm not sure if that's in the Mint distro. Or, is there some kind of menu item for password manager or key manager, maybe in the system apps? I've never worked in Mint, so I need eyes.
  8. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I just read about Seahorse and it shows you all website and network saved passwords. But it doesn't show me anything for my local accounts. Can the password be reset in /etc/passwd?
  9. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    George can't do anything in /etc/passwd if he's not root.

    Anyhow, that isn't the right solution. I need to know if he has those directories I asked for above. After I know, I'm pretty sure I know what to do.

    But you've answered something; seahorse does exist on his box. That might be useful.
  10. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Here is one possible solution:

    You can reset your password following the next steps:
    1. Boot your computer
    2. hold the shift key - to make the GRUB boot menu show
    3. Use the arrow keys to highlight the second entry in the menu (recovery mode)
    4. Press the 'e' key to edit the boot parameters
    5. Scroll down to the line starting with 'linux'
    6. At the end of that line add "init=/bin/bash" (without the quotes)
    7. Continue the boot and you should drop to a text screen and are now root
    8. Start with mounting the filesystem so that you can write changes to it. Execute the following command:
      Code:
      mount  -o remount,rw  /
    9. Then type:
      Code:
      passwd username
    10. Where your replace username with your username. You are then asked to enter a new password for this user
    11. reboot
    or
    1. Reboot your computer / Turn your computer on
    2. Hold down the Shift key at the start of the boot process to enable the GNU GRUB boot menu (if it does not show)
    3. Press ESC at the GNU GRUB prompt
    4. Press e for edit
    5. Use the Arrow keys to highlight the line that begins with kernel and press the e key
    6. Go to the very end of the line and add rw init=/bin/bash
    7. Press Enter and then press b to boot your system
    8. Your system will boot up to a passwordless root shell
    9. Type in passwd yourusername
    10. Set your new password
    11. Restart your system

  11. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Be careful; we're not talking about his login password here, Brian. What you posted is related to that.

    We have to know if he has set a keyring password, and that is a completely different thing.
  12. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Oh, but he couldn't "sudo" which is the same as his login...
    The keyring (seahorse) on my Mint box doesn't show any local accounts or passwords

    The only reason he "can" login is because Mint will do an automatic login so you don't have to type the password each time
  13. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Just hang in there, if he has keyring files we just delete/rename them. It's unnecessary to have them as the sole user, anyhow.

    Then we reboot him and it should be gone.

    I think you'll find the stuff we need in seahorse: view menu/by keyring

    but I don't have it installed, so I'm not 100% sure.
  14. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    But why would he need to use sudo when using his keyring?
    When I typed:
    Code:
    seahorse
    it doesn't ask for a password
    Cloasters initial problem was using "sudo" and I have a feeling its not resolvable with keyring
  15. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    He's getting selection boxes from apps asking him for a keyring password. This happened to me before in Gentoo, and the solution was to delete the gnome-keyring files.

    I'll bet your seahorse doesn't ask for a password because you have set it that way, intentionally or not. I'll also bet that his isn't set that way; so the system asks him for a password and he's getting confused. Most likely, he has a blank password set. I'm sure he did not set a new password randomly. Probably if he just hits unlock when asked, he will proceed, without entering anything in the field.

    In other words, there's a master password that allows the normal password to function. It is either blank, or the SAME password, because he didn't set something new, I'm sure.

    Oh, and I'm still waiting to find out how he was using sudo, and what he was invoking. That's important.
  16. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,877
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Your system might not ask for a password because you selected 'remember for this session' or something to that effect. If a user doesn't make that selection, the pw will be requested every time.

    In this case, we can eliminate that by simply deleting the keyring. There's no danger in that. Then we can see if there's something else as well.

    After midnight here, hoping Geo would check in, but...zzzzzzzzzz

    See y'all tomorrow
    Last edited: Mar 15, 2016
  17. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,073
    Likes Received:
    117
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    Boo, I think Thunder is on the right track here; it really sounds to me like George has managed to get his keyring and login passwords out of sync. But again, we need to know what George was trying to do with 'sudo' that launched this whole conversation so that we can be sure of the footing we are on.
  18. cloasters

    cloasters Well-Known Member

    Joined:
    Jul 3, 2013
    Messages:
    3,099
    Likes Received:
    53
    Trophy Points:
    48
    Thank you all very much for your time and effort on my behalf!
    Embarrassing but true, I don't remember what I was trying to do with "sudo." I apologize!
    I have the automatic login to Mint feature, which I don't like. I don't know how the having to enter password to boot feature was de-selected, but I don't like it this way.
    It sounds like I don't need the "key ring" feature because I'm trying to run Chrome with as little baggage as possible.
    But truthfully I'm mighty confused at this point, sorry.
  19. cloasters

    cloasters Well-Known Member

    Joined:
    Jul 3, 2013
    Messages:
    3,099
    Likes Received:
    53
    Trophy Points:
    48
    "No such file or directory for gnome/keyrings,"
    and "No such file or directory for /.local/share keyrings." (I typed in the whole lines as directed.)
    Thanks everyone!
  20. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,073
    Likes Received:
    117
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    You missed the leading ~.

    It needs to look EXACTLY like this:

    Code:
    ls ~/.gnome2/keyrings
    and this:
    Code:
    ls ~/.local/share/keyrings

Share This Page