1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warframe: Game Guide

Discussion in 'Guides' started by batmanm0b1e, Sep 22, 2018.

  • by batmanm0b1e, Sep 22, 2018 at 9:19 PM
  • batmanm0b1e

    batmanm0b1e Active Member

    Feb 12, 2018
    Likes Received:
    Trophy Points:

    They were called Tenno. Warriors of blade and gun: masters of the Warframe armor. Those that survived the old war were left drifting among the ruins. Now they are needed once more.

    The Grineer, with their vast armies, are spreading throughout the solar system. A call echoes across the stars summoning the Tenno to an ancient place. They summon you.

    Allow the Lotus to guide you. She has rescued you from your cryostasis chamber and given you a chance to survive. The Grineer will find you; you must be prepared. The Lotus will teach you the ways of the Warframes and the secrets to unlocking their powers.


    Follow my step-by-step guide on installing, Warframe in Linux with Steam-Proton

    Note: This guide applies to Steam-Proton. Only on Steam. It delivers DXVK and wine, tools by steam,winehq,codeweavers.

    To learn more about proton see here Proton Explained

    I'm using Arch. You can use Ubuntu or any Distro of choice
    Arch 64bit Manjaro
    Steam-Proton-3.7-6 Beta

    Steam Proton Installation Setup

    Please have the following installed on your Linux
    Note: have the most updated Nvidia drivers installed 396,54 if you're on Intel or AMD you need mesa
    Note: If your game Starts every time in windowed mode and the save does not take effect for your resolution. Remove -fullscreen:0 from line 422 in Launcher.sh from
    (Mesa for Intel & AMD) only Intel & AMD

    For Intel and AMD Users with no Nvidia
    sudo add-apt-repository ppa:paulo-miguel-dias/mesa
    sudo apt dist-upgrade
    sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386
    Install Steam for Ubuntu and Debian - You might need to add a repo if you're on an older Ubuntu
    sudo apt install steam
    Install Arch Linux
    sudo pacman -S steam
    Install Vulkan and Vulkan-32bit

    Install Vulkan on Ubuntu and Debian

    sudo apt install libvulkan1 libvulkan1:i386
    Install Arch Linux
    sudo pacman -S vulkan-icd-loader lib32-vulkan-icd-loader

    Now that is done and you have everything
    open Steam and go to Settings"
    Now go to your account and change to Beta updates for Steam Play. It will Restart Steam and Update
    Let it do its thing it should take more than a few seconds


    Once done Go back to Settings-Steam Play- Select Proton 3.7.6-Beta checkmark all three boxes


    It will Restart Steam again Now that Proton is set

    Now Go to the Store and find Warframe you should now see an install button. Now go to Library and it will say installing but will say steam proton next to the play button. Wait for it to install and try and launch it. (It won't launch) This is ok we needed an initial start for proton

    Now go to your $HOME/username/
    and find /.local/steam/steamapps/common/
    Now find the Proton 3.7 Beta Folder

    Go here and change user_settings.sample.py to user_settings.py
    Once done open the python file with a text editor I'm using mousepad. Make sure unhash the DXVK_HUD if you want it.


    Now that this is complete.
    We have to go get some files from an awesome guy who has been making Warframe work in Lutris for a long time now in wine and DXVK. His name is GloriousEggroll. If you like what he has done thank him and donate to him.

    Note: GloriousEggroll says
    You will need to plug in a controller. Proton auto-closes warframe after a few minutes if it does not detect one. You do not have to use the controller to play.

    I'm using XBOX360 controller I have it plugged in but not using it
    I haven't tested if it works without one but any USB controller that you have that works with steam will work you do not have to use it if you don't want too

    Go here and Download https://gitlab.com/GloriousEggroll/warframe-linux/tree/steamplay-proton pick and choose your format I choose zip archive. Then extract it somewhere you want to keep it mines in /.Downloads/.


    once you have those files extracted we need to copy all of them to here and replace all (if dialog box appears)
    In your $HOME/yourusername/
    Before you copy the files from here. Copy Launcher.exe and rename it to Launcher.backup or whatever just so you have a backup copy of original


    Now you are good and done and we are finished. Now Start Warframe in Steam and you should get a white terminal box. It will update everything let it do its thing should only take 10-20mins depending on your CPU prob, not even that once its done it will open Warframe in windowed mode and you will have to set your Resolution.


    Everytime you start Warframe you will get this white terminal box it will check updates and then open Warframe this is good

    If you want a higher FPS, Turn off Vsync. But I do not recommend it. Only if you're not getting the FPS you want. Make sure you know what FPS you get in Games and know your internet speed.
    Then you can set it to your right FPS. If its too high your CPU and GPU will go up. Unless Warframe Devs fixed this

    Gameplay Video:







    Last edited: Sep 24, 2018


Discussion in 'Guides' started by batmanm0b1e, Sep 22, 2018.

  1. batmanm0b1e
    I don't have those launch options in steam
  2. batmanm0b1e
    yeah i know those are there in the launcher.sh. as i said above if you don't have fullscreen to remove -fullscreen:0 but that's not the case here as you said the white terminal box isn't even coming up to launch the game
  3. booman
    Very strange...
    Looks like I have everything set properly, but still no go...
    It tries to launch, shows Warframe - Running
    Then closes
  4. batmanm0b1e
    Did you download those files and copy everything in /home/batman/.local/share/Steam/steamapps/common/Warframe/Tools/
  5. booman
    Gonna play guitar for a while, then will try again in the morning.
    I'm destined to never play Warframe.
    This is my 4th or 5th try
  6. batmanm0b1e
    try this open up Launcher.sh in text editor go to line 51 change Warframe.exe to Warframe.x64.exe try launching it
  7. booman
    My guess is that its not even executing the Launcher.sh
  8. booman
    Its working now!!!

  9. booman
    Dang, so close
    The Launcher.sh is running and updating, didn't take 10-20 minutes, but then Warframe closes again
  10. batmanm0b1e
    did it finish with that terminal stuff updating and cache, optimization,defrag
    Now change it back to Warframe.exe in launcher.sh run again see if it works
  11. tuxtergames
    I have this issue here on fedora, then I change to ubuntu and bang! runs like a charm, be sure to install that libs to work " xz-utils, curl and md5sum" i used synaptics to install, on fedora I try to run but script fails to start, btw I have one issue now on ubuntu, the game just close after a few minutes playing, if I find something I'll post here.
  12. booman
    Already tried that and it still runs Launcher.sh but closes after a few seconds.
    Hard to tell what the terminal does cause its so quick
  13. batmanm0b1e
    aaah ;) Thanks tuxtergames. you do need these packages xz-utils, curl and md5sum. But your system should already have them installed by default. If not install them.
  14. batmanm0b1e
    Did you get it working sorry long day today 7hours and back from Dr office
  15. booman
    I tried again this morning and still no go
    The reason Launcher.sh even started working is because I removed all of those Launch Options
    Not sure why it never launches

    Sorry I'm being such a baby about this. I've already given up on Warframe before... this was my last hope.
  16. booman
    I wonder if I should try again with PlayOnLinux and DXVK?
    I never used the GloriousEgroll script, because I didn't understand what to do with it?
    Now I kinda understand.
    Previously I was able to launch the Warframe Launcher and sign in. Once I was able to run it with staging Wine and the game launched and played, but lots of graphical artifacts.
    Then I tried with DXVK in PlayOnLinux and I got the initial loading screen which hung indefinitely
  17. tuxtergames
    booman likes this.
  18. booman
    Awesome! Thank you tuxtergames
    Apparently there is a --firstrun flag as well.
    I will try both commands to see what is going on...

    Also, in that thread, the problem was a 32-bit Wine when Warframe is 64-bit.
    How do I select a 64-bit Proton in Steam?
    There isn't really an option for that.

Share This Page