1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Battle Realms Guide

Discussion in 'Guides' started by booman, Jan 1, 2016.

  • by booman, Jan 1, 2016 at 1:35 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Arizona
    Home page:

    Battle Realms is a Real Time Strategy game with an Oriental Mythology theme. Turn ordinary villagers into Samurai, Bandits, Geisha and more... Defend your village from barbarians, evil magicians, and deadly ninjas.


    Follow my step-by-step guide on installing, configuring and optimizing Battle Realms in Linux with PlayOnLinux.

    Note: This guide applies to the GOG version of Battle Realms. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.9
    Wine: 1.6.2

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.6.2
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.6.2 is installed and you can close this window

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install

    Click "Install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name the virtual drive: battlerealms
    Click Next

    Check all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine: 1.6.2
    Click Next

    Select "32 bits windows installation"
    Click Next

    Wine Configuration

    Application Tab
    Windows Version: Windows 7
    Click Apply

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual drive"
    Desktop size: 1024x768
    Click OK

    PlayOnLinux Packages (Libraries, DLL's, Components)

    Check the following Packages:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_tahoma
    Click Next

    Note: All packages will automatically download and install

    Installing Battle Realms

    Click Browse

    Select "setup_battle_realms_complete_2.0.0.0.exe"
    Click Open

    Click Next again

    Click Option
    Uncheck "Create desktop icons"
    Check "Yes, I have read an accept EULA"
    Click Install

    Click Exit

    PlayOnLinux Shortcut

    Select "Battle_Realms_F.exe"
    Click Next

    Name the shortcut: Battle Realms
    Click Next

    Select "I don't want to make another shortcut"
    Click Next

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Battle Realms"
    Click Configure

    General Tab
    Wine version: 1.6.2

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine

    Display Tab
    Video memory size: Enter the amount of memory your video card/chip uses

    Close Configure

    Launching Battle Realms

    Select Battle Realms
    Click Run

    Note: Click Debug to see errors and bugs


    Click Options

    Click "Game Options"

    Adjust Resolution
    Adjust Level of Detail

    Click Apply
    Click Ok

    Battle Realms installed and played just fine in PlayOnLinux with my GeForce 550 Ti. The highest resolution is 1024x768 so you will need to set your Linux Desktop resolution first in order for the game to appear fullscreen. Otherwise, just play it windowed.

    Gameplay Video:




    Last edited: Jan 13, 2016
    mrdeathjr28 likes this.
  • Categories:


Discussion in 'Guides' started by booman, Jan 1, 2016.

  1. mrdeathjr28
    Good guide and good screens

  2. booman
    Thanks as always!
    I wonder if the widescreen patch is worth it?
  3. mrdeathjr28
    In my case dont have any preference with wide or not wide aspect, however for other users can be disgusting

    But in my case have Samsung Syncmaster 794MB - 17 inches CRT, sometimes have access to Samsung Syncmaster T22B350 - 22 inches FullHD TV-Monitor Combo but in my case i like more crt because have minor input lag

    booman likes this.
  4. Marlhin
    I've followed your guide but when starting the game although I can hear the intro movies and the main menu music, I have a black screen. All I can do is quitting the game via Alt+F4.
    Video driver is installed and up-to-date. Games like CS:S and CS:GO are working properly. I guess it has something to do with wine.
    I am using version 1.8.3 but I also testet 1.9.16 staging with the same outcome. I also testet several options in the video section of the wine configuration screen.
    At the moment I am using kernel 4.7.2-1 on Arch Linux.
  5. booman
    Hey Marlhin, I never tested Battle Realms with Wine 1.8.3 or 1.8.4 there is a chance it will only work with 1.6.2, but I doubt it. Give 1.6.2 a try and also mess with the virtual desktop. You might not need it at all.

    Are you using the GOG version too?
  6. Marlhin
    Thank you for your reply, booman.
    With a virtual desktop battle realms works! But I would prefer a fullscreen solution, though...
  7. booman
    Since Battlerealms doesn't support high resolutions, you can set your Linux desktop to match the games highest resolution. Then the virtual desktop will make it appear full-screen.
    Let me know if you have this issue with any other games. I'm experiencing a strange issue with all my games and virtual desktop
  8. Marlhin
    Ah, I forgot to mention that I am using the GoG Version.
    The game always starts in the same sized window so that the lowest buttons for example in the main menu are hard to hit.
    Check this screen out: [​IMG]
  9. booman
    Looks like I was running it at 1024x768
    Were you able to select 1366x768 in-game?

    You can set the virtual desktop at 1366x768 and it should work.
  10. Marlhin
    I have a desktop resolution of 1366x768 and when I configure my virtual desktop to be 1366x768 the ingame window looks the same. I can only choose 1024x768 as the highest ingame resolution.
  11. booman
    Ok, then change your desktop resolution to 1024x768 and make the virtual desktop 1024x768
    Maybe it will appear fullscreen properly after that

Share This Page