1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wine games not showing videos.

Discussion in 'WINE' started by Felidae, Apr 4, 2020.

  1. Felidae

    Felidae New Member

    Joined:
    Apr 4, 2020
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hey guys, I am new to the linux game stuff, I am trying to setup wine and all the dlls. Something I am kinda stuck is at getting videos to play in games, like intro videos, background ones and so on...

    Right now Im trying to get Battletech up and running with Wine ... no lutris or play on linux...
  2. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,661
    Likes Received:
    547
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Welcome to the forum!
    Video's and Cutscenes are constantly a pain for games. Developer never decide on a single format so they always require something different.

    I've seen this for many games, from Darksiders to Alan Wake. Sometimes I just give up and play the game without the cutscenes.

    Did you try the tips in this WineHQ post?
    https://appdb.winehq.org/objectManager.php?sClass=version&iId=36679&iTestingId=102261

    Sometimes installing a video player like VLC or LAVFilters can fix video issues too. You can do this in PlayOnLinux by clicking the "Configure" button and going to the Miscellaneous Tab, then click "Run an .exe file in this virtual drive"

    But like I said, some games just can't play videos in Wine. When I test games, I specifically make sure the game-play its self works good to consider it a success.

Share This Page