1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems starting path of exile

Discussion in 'PlayOnLinux' started by nrKst, Mar 1, 2015.

  1. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    problems starting path of exile

    hi there,

    I have a lot of questions. i do apologize up front for: my bad english and redundance/wrong question at the wrong place - still asking in hope of you ppl being super kind.

    I. Why can`t I pm "booman"? wouldve made this thread unnessecary.
    II. Why does "playonlinux" show me the following message: "Could not find any compatible Direct3D devices."
    III. why does "playonlinux" show me the following error: "DXUTCreateDevice failed"
    IV. why does ... following Exception: ""Metadata/Effects/Spells/fairgraves_spectral_throw/torment_spectral_throw_sword.ao": "": No bone group with name blade"
    V. following Exception: ""Metadata/Effects/Spells/fairgraves_spectral_throw/torment_spectral_throw_sword.ao": "Metadata/Effects/Spells/fairgraves_spectral_throw/torment_spectral_throw_sword.ao": "": No bone group with name blade"



    further information:
    I installed everything exactly the way it is explained in this article: http://www.gamersonlinux.com/forum/threads/path-of-exile-guide.236/page-2
    linux mint 16 cinnamon 64-bit
    intel pentium cpu B950 @ 2.10GHz x 2
    3.8 gb ram
    graphiccard (onboard - its a laptop): intel corporation 2nd generation core processor family integrated graphics controller

    ppl are playing PoE with the graphiccard (since I thought it wouldnt work): http://www.game-debate.com/games/index.php?g_id=1399&canMyGpuRunIt=Path of Exile

    i think it has something to do with the drivers but im not sure. another problem is that im trying to make it work for a friend of mine. which means that im not used to linux mint. i used to be used to "debian stable" but thats a long time ago...
    i apreciate every kind of help. after 10hours of trying/installing/reinstalling reading forum xyz i gave up. i am sorry -.-

    have a nice day
    nrKst
  2. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    1,876
    Likes Received:
    65
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    The best thing to do - always - when you have troubleshooting like this is to post in the forum, not PM a member. PM'ing your member of choice will most likely result in no help at all; we do our business on an open forum for a reason, and that is so others can benefit from the work.

    You account is also limited for a short period of time when you sign up, and you're most likely not able to PM anyhow.

    There are a group of people who work here that can help you, just hang in there and let it happen. More eyes on the issue = better, faster help for you. Your posts will be subject to moderation until you have 10 accepted posts. As you see, I've moderated and permitted this one as your first. You might have to wait for a few hours until your posts get moderated in the beginning. Our apologies for that, but this is a guard against spammers, of which we have many, and the posts are all moderated manually.
  3. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thank you very much.

    yea i thought new accounts would be pmbanned - makes perfect sense. in any case. thank you of royur moderation. i will wait. still i want to say: since booman seems to be an expert i thought it would be faster to just talk to him but you have a point.

    nrkst
  4. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Welcome to the forums nrKst.
    Posting here is the best place to start because anyone can help you with your Path of Exile troubleshooting.

    Thank you for so much detail in your post.
    I have a feeling this is a driver issue as well.

    Where are you seeing those errors in Path Of Exile?
    What version of Wine are you using?
    What version of PlayOnLinux are you using?

    Double-check to see if the Intel drivers are installed in Linux. Mint should automatically install them for you, but it depends on how old your laptop is.

    Go to:
    1. Menu
    2. Administration
    3. Driver Manager
    Does it show Intel Proprietary drivers installed?
  5. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi there,

    i want to add: when i start pol i get a little error (not poe related - thats why i missed posting it earlier but it may help you ppl...): "PlayOnLinux is not able to find 32bits OpenGl-Libraries" - sorry if thats another huge information...

    "Where are you seeing those errors in Path of Exile?"

    right at the start. the client appears for a ms or so (long enough that you can spot it buw not long enough to read/etc. anything) the mouse cursor turns into the PoE cursor style thingy, screen is black looks like it is going to load the "grindingGearGames" loading screen and thats the exact moment the errors etc accure in the order you see above.

    "What version of Wine are you using?"

    1.7.19-WGL_WINE_surface2 - that is the wine version you are advising. see: http://www.gamersonlinux.com/forum/threads/path-of-exile-guide.236/page-2

    "What version of PlayOnLinux are you using?"

    Version: 4.2.6

    "Does it show Intel Proprietary drivers installed?"

    nope. it clearly states: "Es werden keine proprietären treiber verwendet" which translates into: "There are no proprietary drivers installed"

    -i get the enhanced feeling that we/you are at the right spot! how do i install drivers with linux mint (keep in my mind: im trying to help a friend i am a nobody with linux and any other os. im just a gamer :))?

    thanks for your answers so far,
    nrKst
  6. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Thank you for all the information.
    I think there are two problems here:
    • 32-bit libraries
    • Intel proprietary drivers
    To install 32-bit libraries, use the Software Center or Synaptics Package Installer
    Search for "multi arch" or "32ia-libs"
    Install those and restart Mint

    Since the Intel drivers did not install automatically, there is a chance the Video chip isn't supported on Linux.
    You can try using the Intel Linux Graphics Installer
    Try installing the one for Ubuntu
    I've used this on my Chromebook with Ubuntu 14, but my Intel HD 2000 chip was not supported.
  7. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    so...

    i installed all three things and now the problem changed from: "Could not find any compatible Direct3D devices." to: "Failed resetting Direct3D device objects.". i am happy i have a new problem. feels like progress :)
    btw. the other errors etc. do not accure...

    where do i go from here?

    sincerly,
    nrKst
  8. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    What happened when you tried the Intel Linux Graphics Installer?
    Did it do anything?

    Unfortunately Path of Exile will require some graphics drivers in order to run properly.
  9. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    damnit. it says distribution not supported...
  10. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I forgot you are on Mint 16, those Ubuntu installers will only work on Mint 17.
    It might be time to upgrade...

    I wonder if you upgrade to Mint 17 if the Intel drivers will install automatically?
  11. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hej thx for all the help ive got the game running now but when i try to change the shadow quality to "off" it kinda freezes. which means it takes very very long to apply the changes - i usually give up after 15 minutes. and when i try to select a character and play thegame i get the following message: "Unable to create texture. D3DERR_NOTAVAILABLE Not Available."

    thank you very much so far.
    btw i still had to sed fullscreen=true in the config file
  12. nrKst

    nrKst New Member

    Joined:
    Mar 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    ohhh and a little tipp: i cant see any characters and so on. cant see the chip at the start... i can click around for the character selection. sound is fine. but i do not see a single animation...

    all good to you ppl
    nrKst
  13. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,492
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Interesting. How did you get it running? Did you try Mint 17?
    Don't forget to install those 32-bit libraries.
    Are the proprietary drivers installed for your video card/chip?

Share This Page