1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Toshiba Laptop and Mint 21

Discussion in 'Installing Linux' started by booman, Nov 17, 2022.

  1. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    My mother-in-law recently gave me an old Toshiba laptop after we moved to Virginia in October. Its a decent computer depite its age!

    TLDR - No UEFI support, install Mint without a UEFI partition on internal drive

    Toshba Satellite L670 PSK3AU-0P902S
    Processor: Intel Core i3 380M (2-core)
    RAM: 4GB (Samsung DDR3)
    Graphics Adapter: Intel Graphics Media Accelerator (GMA) HD Graphics
    17" Screen

    upload_2022-11-17_9-16-12.png

    From the beginning I started having some issues...
    I already had a USB flash drive with Mint 21 on it and tried to boot: Nothing
    The BIOS wouldn't boot to the drive at all, just showed "Failed" as the error

    So naturally I tried a spare USB flash drive that was older because I was thinking maybe it was the USB 3.0 flash drive causing an issues. Nope, older USB didn't boot either.
    Ok? Now what?

    This model happens to have a SD port for scan disk drives. I happen to have an 8GB SD card. So I pop it in and try to install the Mint ISO on it with a spare computer. Failed! UGH, what is going on here? I tried several other times after formating it with Mint's Disk utility. Doesn't matter what format I used:
    • FAT32
    • exFAT
    • NTFS
    I gave up on this option and started searching online.

    After a bit of research I found that this laptop doesn't not support UEFI firmware. This is why the flash drive isn't booting, but how can I make it boot via old skool BIOS if the USB flash drive has UEFI?

    One post said to simply delete the EFI directory on the flash drive, but this wasn't possible since it appears as read-only.

    Windows 7 happens to be on the computer so I boot to Windows and ironically my "admin" account still existed and still had the password I setup for my mother-in-law. I used Rufus to make a USB bootable flash drive with Mint 21 on it because there is an option for BIOS or UEFI booting.

    Bam! It worked! I was able to boot to the flash drive and use live Mint!
    Installed Mint on the hard drive successfully and rebooted...
    Nope! Internal hard drive will not boot. BIOS shows "failed" again.... UGH!

    Then I realized when I configured the partition scheme I had to create a UEFI partition for the firmware... but this Toshiba doesn't support UEFI. So I went back, re-installed using live Mint and didn't create the UEFI partition. The installer warned me, but I was like "its worth a try"...

    Whoo hoooo! Now its booting to the internal hard drive!
    Success!
  2. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    2,500
    Likes Received:
    82
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Wow, nice one.

    That's one of those solutions that you go to bed thinking about, after failing over and over again. You wake up the next day and try something new, and suddenly it works.

    Well done.

Share This Page