1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Guild Wars 2 Guide

Discussion in 'Guides' started by booman, Sep 11, 2015.

  • by booman, Sep 11, 2015 at 1:27 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Arizona
    Home page:

    Guild Wars 2 will satisfy any gamer who wants multi-player, roleplaying, looting, responsive storyline, crafting, pets, character development and of course... Combat!


    Guild Wars 2 includes a dynamic event system replaces traditional questing, utilising the ripple effect to allow players to approach quests in different ways as part of a persistent world. Also of note is the combat system, which aims to be more dynamic than its predecessor by promoting synergy between professions and using the environment as a weapon, as well as reducing the complexity of the Magic-style skill system of the original game.

    Follow my step-by-step guide on installing, configuring and optimizing Guild Wars 2 in Linux with PlayOnLinux.

    Note: This guide applies to the Free-To-Play version of Guild Wars 2 downloaded from their website. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.8
    Wine: 1.7.49-staging

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.7.49-staging
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.7.49-staging is installed and you can close this window

    Go to: https://www.guildwars2.com/
    Click "Play For Free"

    Signup and login

    Click "Windows Client Download"

    Download the client from here:

    Save Gw2Setup.exe on your desktop

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install

    Click "Install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name your virtual drive: guildwars2
    Click Next

    Check all three options:
    • Use another version of wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine: 1.7.49-staging
    Click Next

    Select "32 bits windows installation"
    Click Next

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1024x768
    Click OK

    Installing PlayOnLinux Packages (Libraries, DLL's, Components)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    Click Next

    Note: All packages will automatically download and install

    Click Browse

    Navigate to your Desktop
    Select "Gw2Setup.exe"
    Click Open

    Click Next

    Loading screen

    Click "Install Guilde Wars 2"

    Click OK

    Sign in
    Wait for preloading...
    Click Ready

    License Agreement
    Click "I Accept"

    Select a server in your area

    Create a character or play as an existing character
    Close Guild Wars 2 and continue with PlayOnLinux

    PlayOnLinux Shortcut

    Select Gw2.exe
    Click Next

    Name the shortcut: Guild Wars 2
    Click Next

    Select "I don't want to make another shortcut"
    Click Next

    PlayOnLinux Configure

    Select "Guild Wars 2"
    Click Configure

    General Tab
    Wine version: 1.7.49-staging

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    Video memory size: Enter the amount of memory your video card/chip uses

    Close Configure

    Select "Guild Wars 2"
    Click Play

    Note: Click Debug to see errors and bugs


    Click the gear or press ESC
    Select Options

    Graphics Options

    • Resolution
    • Refresh Rate
    • Frame Limiter
    • Interface Size
    • Gamma
    Advanced Settings

    • Animation
    • Environment
    • LOD distance
    • Reflections
    • Textures
    • Render Sampling
    • Shadows
    • Shaders
    • Postprocessing
    • Character Model Limit
    • Character Model Quality
    • Ambient Occlusion
    • Best Texture Filtering
    • Depth Blur
    • Effect LOD
    • High-Res Character Textures
    • Light Adaptation
    All changes happen real-time


    Disable Preloading

    Click the Wrench Icon
    Scroll down to Streaming
    Select "On Demand" from the drop-down menu

    Note: This requires downloading the entire game on next launch, but can improve performance.

    Guild Wars 2 installation was simple and straight forward. Launching the game is slow on the first try, but tweaking the graphics requires a bit of patience. Make sure to use an Nvidia Geforce video card and the proprietary Nvidia drivers for best performance. My GeForce 550 Ti was able to run Guild Wars at a playable frame rate, but I was not able to crank all the display settings to high.

    I found that disabling Streaming and turning down Shaders & Antialiasing improved performance without loosing too much eye-candy.

    Gameplay Video:






    Last edited: Jan 13, 2016
    vashin likes this.


Discussion in 'Guides' started by booman, Sep 11, 2015.

  1. TheDaftRick
    You should enable CSMT under the Staging tab in the WINE Configuration.

    Having my textures on high seems to cause my game to crash after playing for a bit.
    Turning it to low seems to fix it.
  2. TheDaftRick
    In the PlayOnLinux configuration window, adding -dx9single to arguments increases performance a ton.

    I don't think Corefonts, d3dx9, or Tahoma are needed, I installed the game without any and I don't see any problems
  3. booman
    In configure where it says arguments?
  4. TheDaftRick
    booman likes this.
  5. iceCalt
    Have a look at the general tab. There's a field for arguments.
    booman likes this.
  6. Tuna
    Howdy, I followed the guide as listed above however after adding "gw2" as a shortcut (after installation) one of two things have happened (as I tried twice).

    First time as I opened up "Guild Wars 2" (gw2.exe) the loader started redownloading Guild Wars 2, after fully downloading again I logged in and clicked "Play" - Agreed to the T&C and clicked accept - however all I got was a black box where GW2 should of been displayed and could hear what I assumed to be the games menu music but no video.

    I deleted the virtual drive and installed again, this time adding all the options available to me (I forget the name of the other shortcuts but there were 3). I tried the alternative two first (which launched the loader, just as the GW2.exe did) but all three of them failed again.

    As for now I've deleted them all and as of this moment accept defeat, however with any advice or tips (as I'm very new to Linux/Wine/PlayOnLinux in general and am also a bit of an idiot!) I'll be willing to give it another pop.

    Anyway, I've got my GPU propietary drivers installed and will provide a link to the output of my "sodu lshw" below.

    Again, thank-you for the guide and thank-you for reading!

  7. allenskd
    How's the game been for you mr. boo sir? I've been playing plenty of it since last week, mostly World vs World.
    booman likes this.
  8. booman
    Hey Tuna, glad you could finally post here.
    Before deleting the entire virtual drive again, lets check the debug
    If you select "Guild Wars 2" and click debug instead of Run
    A window will pop-up and output errors, fixme's and a bunch of other stuff.
    Please post this debug in our PlayOnLinux forum so we don't clutter up the conversations here with long error files.

    Are you able to play other games in PlayOnLinux?
    Did you install 32-bit libraries for 64-bit Linux distros?
  9. booman
    I actually had to uninstall Guild Wars 2 so I could have enough space to install a new game to test. I had no idea Guild Wars 2 was 32GB of data!!!
  10. allenskd
    Yep! It's pretty big, Final Fantasy XIV is also around that size, and I think The Elders Scrolls Online too. It's pretty insane yet seem to be what we'll be expecting in the future...

    I thought you would be playing it with the family, haha. Really recommend it. :]
  11. booman
    The biggest I've see so far is Tera: 42 GB
    I didn't have enough space on any of my machines to download it and test it.
    I don't understand why its so big when games like Neverwinter and Skyrim are under 10 GB
  12. Tuna
    I will post any findings to your post here;

    Hopefully this is the right place (and hopefully it's not an issue replying again!)
    Thank-you so very much for the reply and help - I will keep you posted and will probably next be able to give it a go on Wednesday, so speak to you then!

    -Kind regards

  13. booman
    No problem, I hope that everyone can enjoy Linux and gaming.
    Were you able to install those 32-bit libraries?
  14. Tuna
    Hey there Booman, thank-you again for being so polite and noob friendly with me, I'm VERY grateful, I managed to install GW2 again but with the same problem (No video, just the music).
    Where you ask if I was able to install the 32-bit libraries I'm assuming you (hopefully!) meant when setting up the PoL virtual drive? I ran the debug and have the log but don't want to ramble and post too much here - as you mentioned doing it on the forms, so with that said if you could message me or reply with everything I can give you and tell you I can reply on the forum thread previously posted - as I said thank-you so much for being so helpful and taking time out to reply to me.

    -King regards

  15. booman
    I'm not sure which Distro you are using...
    32-bit libraries have to be installed to play most games. Specially in PlayOnLinux (Wine)
    In the past Ubuntu made a package called ia32-libs which you could install.
    It would handle all of the 32-bit libraries required to run programs.
    Tuna likes this.
  16. Tuna
    Hello, I'm terribly sorry - I'm using Linux Mint, I'm sure I mentioned that but apparently not - deeply sorry. The only 32bit I remember was on the "32 bits windows installation" / "64 bits windows installation" - of which I clicked 32 - other than that I've not done anything other than explicitly what the guide has mentioned.

    If there is more (or rather, other items I should download) it would be ever so kind if you could list them here & also I'm unsure if I should be posting in the forum link I posted or here (as I don't want to cause clutter!).

    Sorry for the delay in my reply, my partner was taken into hospital and I've only just got back..

    Again, thank-you for the time and help, you're a star!

    -Kind Regards

  17. booman
    Don't apologize! I love to help!

    Ok, since you are using Mint, go to:
    • Menu
    • Software Installer
    • Search: ia32-libs
    • Double-click
    • Click Install
    It might be a good idea to restart, not sure if you have to or not.
    Then try launching Guild Wars 2 again.
    Tuna likes this.
  18. Tuna
    Thank-you so much Booman for explaining that as simply as possible, I would of gotten lost otherwise! I looked up "ia32-libs" and it said it was installed already - bummer..

    I ran it under a debug and closed it (after the game "launched" only playing sound) but I'm unsure if it'll help if I'm honest (link here; http://dumptext.com/bmq7qnd7 )
    I'm sorry to not be able to report any good news :( hopefully this will help as I'm starting to think I'm cursed with games in general lol!

    Thanks again so very much for your time and knowledge - be well and hope to hear from you soon.


  19. booman
    Thank you for posting the debug.
    Unfortunately this might be a results of AMD drivers... really hard to tell.
    You may have to update to the newest driver, but its not an easy thing to troubleshoot if the install goes wrong.

    There are a lot of errors like this one:
    The /usr/lib/i386 means 32-bit library is missing.

    We can try checking for ia32-libs in Synaptics Package manager, but the Software Manager doesn't lie.

    I'm going to research your video card and see if others have similiar problems and how they solved it. You may want to do some searching online as well.

    If you have a desktop, I suggest purchasing a new GeForce card and you will have a lot of success with game in Linux. Sad I know, but until AMD catches up with drivers, Nvidia is winning
    Tuna likes this.

Share This Page